Sign in to follow this  
Followers 0
Tom_Weiss

Lock On 1.1xx FPS Tweak v2.0G7

15 posts in this topic

File Name: Lock On 1.1xx FPS Tweak v2.0G7

File Submitter: Tom_Weiss

File Submitted: 30 Jul 2005

File Updated: 12 Dec 2012

File Category: FPS Tweaks

- UPDATED MAR 09 2009 -

SHOULD BE USED WITH LOCK ON 1.12A OR B

This is an FPS tweak for Lock On 1.1XX FC, tweaked for BETTER FPS, less stutter with high settings , it is set @ 1024X768 32BIT for install compatibility.

COMPATIBLE WITH ANY CRIMEAN AIR WARS Mod

compatible with 3GO Su-27 Model

In this Tweak you will find:

- an FPS Tweak optimization and Labels Configured for more realism

- Labels tweaked

- TekaTeka HUD Mint Green Color change

- TekaTeka View Rotation tweak implemented

- Cockpit Mouse enabled

- Force Feedback disabled

- Target Visibility at distance improved

- ground 'white line' fixed

enabled Civilian traffic and Scene Low and High modes

Compatible with SIMMOD A-10 and WALMIS F-15

- this tweak DOES NOT include an MEInit file

you need to edit before running it the resolution to fit the one you Monitor uses: this is the part of the code found it the graphics.cfg found in the CONFIG folder



DisplayMode
{
resolution = {1600, 1200};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
Interface
{
resolution = {1600, 1200};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
}
Simulation
{
resolution = {1600, 1200};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
}
AVI
{
resolution = {640, 480};
fullscreen = 0;
aspect = 1.3333;
}
}[/code] you need to edit
[code] resolution = {1600, 1200};
bpp = 32;
fullscreen = 1; aspect = 1.333333373;

the resoultion and aspect ratio

Click here to download this file

Share this post


Link to post
Share on other sites

I recently noticed while doing a clean install of Lockon 1.12b, that the FPS mod v2.0G7 will install correctly but does not show up in the options field so I can select the level which I want to use. Is this a recent change as to how the mod should work?

If anyone has any ideas as to what is causing this, I would appreciate the help.

Thanks

spn

Share this post


Link to post
Share on other sites

open the file CONFIG/graphics.cfg

see if you can find these lines



{
current = "TWEAK2G7";
Low
{
near_clip = 4;
middle_clip = 4;
far_clip = 60000;
structures = {40, 5000};
trees = {60000, 3000};
dynamic = {300, 20000};
objects = {3000, 40000};
mirage = {3000, 10000};
surface = {10000, 50000};
lights = {50, 10000};
lod = 0.7;
}
Medium
{
near_clip = 0.2;
middle_clip = 4.;
far_clip = 80000;
structures = {30, 2000};
trees = {100000, 8000};
dynamic = {300, 20000};
objects = {3000, 50000};
mirage = {3000, 15000};
surface = {14000, 80000};
lights = {100, 30000};
lod = 1.;
}
High
{
near_clip = 0.2;
middle_clip = 4;
far_clip = 80000;
structures = {200, 10000};
trees = {200000, 15000};
dynamic = {300, 20000};
objects = {5000, 80000};
mirage = {5000, 20000};
surface = {20000, 80000};
lights = {200, 80000};
lod = 1.;
}
TWEAK2G7
{
near_clip = 0.2;
middle_clip = 2.;
far_clip = 60000;
structures = {100, 5000};
trees = {100000, 8000};
dynamic = {300, 20000};
objects = {3000, 50000};
mirage = {3000, 10000};
surface = {14000, 80000};
lights = {50, 10000};
lod = 1.5;
}
TWEAK2G7_HIGH_END
{
near_clip = 0.2;
middle_clip = 2.;
far_clip = 80000;
structures = {200, 10000};
trees = {200000, 15000};
dynamic = {300, 20000};
objects = {3000, 50000};
mirage = {3000, 10000};
surface = {20000, 80000};
lights = {50, 10000};
lod = 1.5;
}
}
[/code]

Share this post


Link to post
Share on other sites

I checked graphics.cfg and the FPS 2.0G7 info was not in the file. I did a clean install of Lockon 1.12b and using Modman 7300, in stalled the FPS mod. Lockon errored out on startup. I removed the FPS mod and Lockon launched without any problems.

Share this post


Link to post
Share on other sites

I am sure Modman did not install the file graphics.cfg

open the Modman pack with winzip or a similar program, extract the graphics.cfg, rename the one you have in the CONFIG folder as _graphics.cfg and paste it, it should run OK

Share this post


Link to post
Share on other sites

I extracted the 2.0G7 file and copied the Graphics.cfg file into Lockon 1.12b and Lockon errored out on startup. I removed the file and let it use the original graphics.cfg file and Lockon started up without any issue. This problem is really not causing me any grave issues. I run Lockon without any problems without it. I just wasn't sure if anyone else had reported the same situation.

Thanks for your help.

Share this post


Link to post
Share on other sites

the reason is probably the resolution that comes with the graphics.cfg, you guys have to edit it to suit the one that you are using

the one that comes with it



DisplayMode
{
resolution = {1600, 1200};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
Interface
{
resolution = {1600, 1200};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
}
Simulation
{
resolution = {1600, 1200};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
}
AVI
{
resolution = {640, 480};
fullscreen = 0;
aspect = 1.3333;
}
}

[/code]

the one that it is using is :

resolution = {1600, 1200};

replace it with the one you use

and don't forget to change the aspect ratio

aspect = 1.333333373;

it should be the ratio of the resolution you are using (in that case : 1600 / 1200 = 1.333333373

Share this post


Link to post
Share on other sites

Hello,

I did this previously and it will let modman 7.3.0.0 install it but it never shows up in the Graphics options to let you select which level you want to use. Maybe it's running in the background and I don't know it but I can't tell.

Thanks

spn

Share this post


Link to post
Share on other sites

I attempted to download another copy of the FPS 2.0G7 mod and got the message "This account has been suspended"

Share this post


Link to post
Share on other sites

I finally got it to work but I am not sure exactly what I did to get it to show up. I did not use modman for the install. I changed the aspect ratios to match my screen sizes (1980x1020)then copied it directly into the config folder from the expanded rar file which I had downloaded and everything started working. I do know that Modman is not installing this mod correctly.

Thanks for your help

Share this post


Link to post
Share on other sites

I think the reason is that Modman tries to insert lines into Graphics.cfg instead of replacing it - something that the previous version did not do when that mod was made

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.